Tests: Move TAP helpers to tests/utils/tap
[babeltrace.git] / tests / lib / Makefile.am
index e846680a4eedd6a305c2dde4722e43cc5a54cff2..6ae694d36b3cfe0183d735b816f4e825d424c87c 100644 (file)
@@ -1,16 +1,23 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
 noinst_LIBRARIES = libtestcommon.a
 
-libtestcommon_a_SOURCES = tap.c common.c
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
-test_seeks_LDADD = libtestcommon.a \
+libtestcommon_a_SOURCES = common.c common.h
+
+test_seeks_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
-noinst_PROGRAMS = test-seeks
+test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
+
+noinst_PROGRAMS = test-seeks test-bitfield
 
 test_seeks_SOURCES = test-seeks.c
+test_bitfield_SOURCES = test-bitfield.c
+
+EXTRA_DIST = runall.sh
 
 check-am:
        ./runall.sh
This page took 0.023925 seconds and 4 git commands to generate.