Always print GIT_VERSION even if empty
[lttng-tools.git] / include / Makefile.am
index 9d00bee4ecb79d73bf49dbb029106798ddaee7c2..89b084d01b45a62bcbd59ce62e04292dfcae5cbd 100644 (file)
@@ -9,7 +9,7 @@ version.h:
        ## the locations of the version.h and version.h.tmpl files
        ##
        @echo -n "Generating version.h ... "
-       @(version_h_tmpl="$(top_builddir)/include/version.h.tmpl"; \
+       @(version_h_tmpl="$(top_srcdir)/include/version.h.tmpl"; \
        if [ -f "$${version_h_tmpl}" ]; then \
                version_h="$(top_builddir)/include/version.h"; \
                ##
@@ -47,19 +47,7 @@ version.h:
                        ## don't want to update the file if it is already up to date
                        ##
                        if [ $$(grep -cE "^#define GIT_VERSION \"?$${git_version}\"?$$" "$${version_h}") -eq 0 ]; then \
-                               if [ $$(grep -c "^#define GIT_VERSION" "$${version_h}") -gt 0 ]; then \
-                                       ##
-                                       ## If there is already a GIT_VERSION defined,
-                                       ## we just replace it by the new version
-                                       ##
-                                       sed -i "s'^#define GIT_VERSION.*$$'#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
-                               else \
-                                       ##
-                                       ## Else, we add a GIT_VERSION define
-                                       ## containing our new version.
-                                       ##
-                                       sed -i "s'^\(#define VERSION_H.*\)$$'\1\n\n#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
-                               fi; \
+                               sed -i "s'^#define GIT_VERSION.*$$'#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
                        fi; \
                fi; \
        fi)
@@ -83,9 +71,11 @@ lttnginclude_HEADERS = \
        lttng/lttng-error.h \
        lttng/snapshot.h \
        lttng/save.h \
+       lttng/load.h \
        version.h
 
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
-       lttng/save-internal.h
+       lttng/save-internal.h \
+       lttng/load-internal.h
This page took 0.024575 seconds and 5 git commands to generate.