Turn health.h/health.c into a library
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 0964c9402c751e5444b76e7890ccf400cd5bf4c1..0fab90f335bc4bd472c8f31b2edf549424d0bb6a 100644 (file)
@@ -9,7 +9,8 @@ bin_PROGRAMS = lttng-sessiond
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-ctl.h ust-app.h trace-ust.h \
+                       ust-ctl.h ust-app.h trace-ust.h ust-thread.h \
+                       ust-registry.h \
                        context.c context.h \
                        channel.c channel.h \
                        event.c event.h \
@@ -21,12 +22,16 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
                        consumer.h \
-                       health.c health.h \
+                       health.c health.h health-sessiond.h \
                        cmd.c cmd.h \
-                       testpoint.h
+                       buffer-registry.c buffer-registry.h \
+                       testpoint.h ht-cleanup.c \
+                       snapshot.c snapshot.h
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
+lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
+                       ust-consumer.c ust-consumer.h ust-thread.c \
+                       ust-metadata.c ust-clock.h
 endif
 
 # Add main.c at the end for compile order
This page took 0.024969 seconds and 5 git commands to generate.