Fix: mi: missing files on make dist
[lttng-tools.git] / src / common / Makefile.am
index 3ba5fed5149ab91ff8536e7566858919b93dd34e..7011d97a64e08f0a3308d1d88f9fff2ebbcc3bf3 100644 (file)
@@ -7,16 +7,22 @@ AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                consumer-metadata-cache.h consumer-timer.h
+                                consumer-metadata-cache.h consumer-timer.h \
+                                consumer-testpoint.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
+EXTRA_DIST = mi_lttng.xsd
 
 libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        common.h futex.c futex.h uri.c uri.h defaults.c \
                        pipe.c pipe.h readwrite.c readwrite.h \
+                       mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h
-libcommon_la_LIBADD = -luuid
+libcommon_la_LIBADD = \
+               -luuid \
+               -lrt \
+               $(top_builddir)/src/common/config/libconfig.la
 
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
This page took 0.025017 seconds and 5 git commands to generate.