Fix: Add test scripts and lists to the distribution package
[lttng-tools.git] / tests / Makefile.am
index 761586e4c6bf18d81d28c463c1db666973f6ca00..c8a85e06d5487c70481e16dd0c2bb1e795c4c933 100644 (file)
@@ -1,11 +1,15 @@
-AM_CFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/libkernelctl \
-                 -I$(top_srcdir)/liblttngctl -g -Wall
-
-noinst_PROGRAMS = test_sessions
-
-SESSIONS=$(top_srcdir)/ltt-sessiond/session.c
-
-test_sessions_SOURCES = test_sessions.c $(SESSIONS)
+SUBDIRS = utils regression unit
 
+if USE_PYTHON
 check-am:
-       ./runall.sh
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+       ./run.sh with_bindings_regression
+else
+check-am:
+       ./run.sh unit_tests
+       ./run.sh fast_regression
+endif
+
+dist_noinst_SCRIPTS = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
+EXTRA_DIST = run.sh unit_tests fast_regression long_regression root_regression with_bindings_regression
This page took 0.024809 seconds and 5 git commands to generate.