Port: Add OSX clock_gettime compat
[lttng-tools.git] / tests / regression / kernel / Makefile.am
index a8c397a854b1aac5210b6272244a73a49eef23ba..e9ec04ea9593dbfbc61005859a7ea4ff4573c997 100644 (file)
@@ -1,5 +1,12 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
 EXTRA_DIST = test_event_basic test_all_events test_syscall \
-               test_clock_override test_rotation_destroy_flush
+               test_clock_override test_rotation_destroy_flush \
+               test_select_poll_epoll
+
+noinst_PROGRAMS = select_poll_epoll
+select_poll_epoll_SOURCES = select_poll_epoll.c
+select_poll_epoll_LDADD = -lpthread -lpopt
+select_poll_epoll_CFLAGS = -fno-stack-protector -D_FORTIFY_SOURCE=0
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.025448 seconds and 5 git commands to generate.