Cleanup: uuid library detection
[lttng-tools.git] / tests / unit / Makefile.am
index f11b69b7c29b83c2e736410f1b95f5c1c607eba0..2c7365912dc106b2ed192252d5bc1e587584896d 100644 (file)
@@ -1,7 +1,6 @@
 SUBDIRS = ini_config
 
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/utils/ -I$(srcdir)
-AM_LDFLAGS =
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils/ -I$(srcdir)
 
 LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
@@ -12,6 +11,8 @@ TESTS = test_kernel_data \
        test_uri \
        test_utils_parse_size_suffix \
        test_utils_expand_path \
+       test_string_utils \
+       test_notification \
        ini_config/test_ini_config
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
@@ -24,13 +25,16 @@ endif
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
 LIBCOMMON=$(top_builddir)/src/common/libcommon.la
+LIBSTRINGUTILS=$(top_builddir)/src/common/string-utils/libstring-utils.la
 LIBSESSIOND_COMM=$(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la
 LIBHASHTABLE=$(top_builddir)/src/common/hashtable/libhashtable.la
 LIBRELAYD=$(top_builddir)/src/common/relayd/librelayd.la
+LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 # Define test programs
 noinst_PROGRAMS = test_uri test_session test_kernel_data
 noinst_PROGRAMS += test_utils_parse_size_suffix test_utils_expand_path
+noinst_PROGRAMS += test_string_utils test_notification
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -110,3 +114,11 @@ test_utils_parse_size_suffix_LDADD += $(UTILS_SUFFIX)
 test_utils_expand_path_SOURCES = test_utils_expand_path.c
 test_utils_expand_path_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON)
 test_utils_expand_path_LDADD += $(UTILS_SUFFIX)
+
+# string utilities unit test
+test_string_utils_SOURCES = test_string_utils.c
+test_string_utils_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBSTRINGUTILS)
+#
+# Notification api
+test_notification_SOURCES = test_notification.c
+test_notification_LDADD = $(LIBTAP) $(LIBLTTNG_CTL)
This page took 0.024222 seconds and 5 git commands to generate.